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About SimaPro 
SimaPro is life cycle assessment software that helps organizations measure and analyze the 

environmental impacts of products across their entire life cycle. Built on extensive datasets and 

established scientific methods, the software provides transparent insights that support product 

development, sustainability strategy, and environmental reporting. 

Used by industry and academia in more than 90 countries, SimaPro enables advanced modeling 

and scalable environmental impact calculations across teams. With more than 35 years of 

development behind it, SimaPro is widely trusted in the global LCA community. SimaPro is part of 

the One Click LCA group. 

 

Contact us 

support@simapro.com  

simapro.com  |  support.simapro.com   
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1 Introduction  
 

This document describes how to update your current SimaPro desktop (formerly SimaPro Craft) 

software and database from version 10.3 to the latest version 10.4. If you are updating from 

older SimaPro version, please follow the Full Update manual instead. In the What’s new in 

SimaPro 10.4 manual, you will find information about the changes in the data, methods and 

software.  

 

The update procedure can be summarized as follows: 

1. Software update: Update your SimaPro single-user or multi-user client software to SimaPro 

10.4. For multi-user licenses, you also need to update the SimaPro database server (see 

section 2.1). 

2. Database update: Import the update database which includes the new and updated data and 

methods. This part can take quite some time, depending on the size of your database. 

Please read on for detailed instructions. Should you still have questions, please contact your local 

SimaPro partner or SimaPro Support by email at support@simapro.com.  

 

 

1.1 What to expect after an update 
In SimaPro, the software is separate from the database. Thus, a SimaPro update consists of 1) 

updating the software components and 2) updating the database contents with additional steps 

like appending substance and replacement of processes. Only after you have done both will you 

have completed the update.  

 

Please note that every update is unique and may contain special instructions for that particular 

update, so please make sure to go through the update instructions carefully. 

 

The frequently asked questions below provide a better understanding of what to expect after an 

update: 

 

• What if I only update the software? 

When you only do a software update you essentially get a newer software version that 

contains new software features and less bugs. Again, it is Important to realize that a software 

update does not change any library, project data or methods in your database.  

 

 

Update video instructions 

The generic SimaPro update procedure for single-user and multi-user installations is also 

explained in a short video series that you can find on this page. For version specific 

instructions, please still check the manual.  

https://simapro.com/wp-content/uploads/2026/04/FullUpdateInstructionsToSimaPro104.pdf
https://simapro.com/wp-content/uploads/2026/04/SimaPro104WhatIsNew.pdf
https://simapro.com/wp-content/uploads/2026/04/SimaPro104WhatIsNew.pdf
https://simapro.com/global-partner-network/
mailto:support@simapro.com
https://support.simapro.com/s/article/SimaPro-Installation
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• After I update the database, what happens to my data? 

Below is an overview of how your data may change – but please keep in mind this depends 

on whether the libraries and methods you are using have been updated in that specific 

release. 

o Library processes: in most cases*, library processes will be automatically updated.  

So, for example, an ecoinvent processes from version 3.11 will be replaced by an 

updated version from ecoinvent 3.12.  

o Custom processes: links to library processes will (in most cases*) be automatically 

updated to link to the newer version of the dataset. The rest remains unchanged. 

o Default impact assessment methods: the default impact assessment methods 

originally provided by SimaPro will be automatically updated (replaced) by the newer 

version – given that you did not change the name of the method.  

o Custom impact assessment methods: these will remain unchanged. 

o Substances: appending may merge one or more synonyms to one substance name 

and could change the result if the “final” substance is included in an impact 

assessment method and the previous was not. 

o For multi-user: the users and user profiles defined on your database will remain 

intact 

*Sometimes there are processes that become obsolete and are not automatically updated.  These 

need additional handling by the user. Refer to section 3.5 for further explanation. 

 

• After a software update, can I expect my results to change? 

No, as you have not (yet) updated the database. 

 

 

• After a database update, can I expect my results to change? 

Most probably yes – that could be due to the changes in the library data or changes to the 

impact assessment method(s) used. 
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2 Updating the SimaPro software 
2.1 Updating the SimaPro database server (multi-user 
versions only) 
 

Single user vs. multiuser  

If you are working with a single user SimaPro license please start with section 2.2. Updating the 

database server is only relevant for multi-user licenses. 

 

We recommend that multi-user updates are done by your network administrator. Please begin 

by updating the SimaPro database server. It is important to note that any defined Aliases remain 

intact after the update. To update the SimaPro database server: 

1. Download the server installation file SetupServer1040.exe to the machine running the 

SimaPro database server. 

2. Important: right-click SetupServer1040.exe and select Run as administrator to start the 

installation.  

3. Follow the instructions in the setup wizard. You may be asked for your SimaPro registration 

name and code. The current SimaPro database server software will be uninstalled and then 

replaced with the latest software. Note that your database(s) will not be uninstalled!  

4. If you have installed the database server as a service: check if the service is running via Task 

Manager. Go to the Services tab, and look for nxSPServer2 to check. If it is not running, you 

can start the service via a right-mouse click. 

 

Next, all SimaPro multi-user clients have to be updated to SimaPro 10.4. This is explained in the 

next section. 

 

2.2 Procedure for updating single-user and multi-user client 
 

 Accessing SimaPro desktop using Integrated Login  

 

Starting with this release, SimaPro uses Integrated Login to securely verify your access before 

opening the software. Please refer to these instructions on how to set it up and complete the 

login process. Once the authentication has been completed, you can continue working as usual 

in SimaPro. Please note that you will need internet connection for daily authentication. If 

SimaPro is used in an offline or restricted environment, we recommend reviewing this 

requirement before updating. 

This procedure does not apply to SimaPro Faculty and Classroom license holders.  

https://pre-support.sharefile.com/d-s2573c5859ac84f679c50c68662edc235
https://support.simapro.com/en/articles/629205-how-to-access-simapro-desktop-using-integrated-login
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The procedure for updating the single-user and multi-user SimaPro client software is as follows:  

1. Download the SimaPro installation file SetupSimaPro1040.exe to each computer that runs 

the SimaPro single-user or SimaPro multi-user client.  

2. Important: Right-click SetupSimaPro1040.exe and select ‘’Run as administrator’’ to start the 

installation. Please make sure all SimaPro instances are closed. Follow the instructions in the 

setup wizard. You may be asked for your SimaPro registration name and code. The current 

SimaPro software will be uninstalled and then replaced with SimaPro 10.4. Note that your 

database(s) will not be uninstalled!  

3. Next, proceed with the database update procedure as described in section 3. 

 

 

3 Updating the database 
3.1 Overview 
 

BEFORE YOU START 

 

Updating/importing a SimaPro database can take some time, depending on the size of your 

database as well as your computer specs. Please be patient throughout the process even when 

SimaPro appears to be unresponsive, as aborting or cancelling the procedure can lead to 

database corruption. 

 

This chapter describes how to update your database. This part can take quite some time – 

depending on the size of your database. The update process consists of four parts: 

1. Installing the update database that contains the new data.  

2. Importing the update database into your SimaPro database(s).  

3. Doing an append action to merge synonyms in the substance list.  

4.  (Optional) Updating obsolete links in your projects.  

These steps are described in detail in the following sections. In Box 1 and 2, you will find tips for 

updating multi-user licenses and an overview of the default database locations. You have to 

follow the database update procedure for each SimaPro database that you want to update. 

 

Updating SimaPro Classroom 

Owners of an educational Classroom license do not have “None (single-user access)”, but 

should request a temporary single-user license via support@simapro.com to do the update 

locally. We will include further instructions on how to update. 

https://pre-support.sharefile.com/d-s0e5bbfde34c84f618acca0be58c49455
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3.2 Installing the Update database 
Download SetupUpdateDatabase1040.exe and double-click the file to install the “Update1040” 

database. Make sure SimaPro is closed otherwise you will receive a warning message. You have 

to do this on each computer with SimaPro single user installed. For the multi-user, one 

installation is sufficient.  

The “Update1040” database will be installed in the default directory (see Box 2 above). Follow the 

instructions in the setup wizard. This process will only install the update database on your 

computer, but it will not yet update the active databases. Please still follow the instructions on 

the next section. 

Multi-user version: since we do not recommend doing the database update via the server, the 

Update database does not have to be installed in one of the locations (directory aliases) defined 

in the SimaPro database server. Instead, you can do the update on a local hard drive and then 

copy your updated database back to the server (see Box 1 above).  

Box 1. Updating a database in a multi-user environment (not applicable for SimaPro Classroom)  

In a multi-user environment, updating a database directly on the database server is very slow 

due to additional network traffic. If you have one of the professional multi-user licenses, you 

need to do the database update locally on a (fast) PC with the SimaPro client installed. This is 

much quicker.  

To do that, log in as Manager and check under Tools > User Management that no users are 

logged into the SimaPro database. If so, you can close SimaPro. Locate the database that you 

want to update on the server’s hard drive (see Box 2 for default locations) and copy the database 

(a set of 77 numbered *.NX1 files) to your local hard drive. In the “Open SimaPro Database” 

window, choose “None (single-user access)” and browse to the directory you copied the database 

to. You may be prompted to enter a password when opening the database so please enter the 

Manager password to proceed. Continue with the update instructions in section 3.3. After 

updating, copy the updated database back to its original location on the server. 

Box 2. Default directories  

SimaPro installs updates in the default database directory if no other location is chosen. The 

default directory for Windows 10 and the supported Windows Server (based on the system 

requirements) is:   

C:\Users\Public\Public Documents\SimaPro\Database 

Some third-party databases will be installed in a subfolder of the default directory. 

If you have a multi-user version and cannot find the database in one of the default directories, 

open the SimaPro database server. In the list of aliases, you can see the location(s) of the 

database directories that are being used. If you still cannot see the database(s) you expect, 

please ask your IT department to check if an alias for the location is defined in the SimaPro 

database server. 

https://pre-support.sharefile.com/d-sb15f8082c215454a9cf7883a33b54c93
https://support.simapro.com/en/articles/504690-simapro-system-requirements
https://support.simapro.com/en/articles/504690-simapro-system-requirements
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3.3 Importing the Update database 

Follow these steps to import the new data:  

1. Start SimaPro. If you have a multi-user license, you need to first copy the database you want 

to update to a local path (make sure no other users are logged in at this moment and during 

the update process). Then open the database via “None (single-user access)” (see Box 1 above 

for further details). During the update process, make sure that no users log in to SimaPro. 

2. Check if the database you want to update is open in SimaPro. The database name is found in 

top left of the SimaPro window. If the database is not open, go to File > Open SimaPro 

Database and select the database you want to update (the database you usually work in, for 

example, the Professional database).  

3. Go to File > Import SimaPro Database. Click “Yes” to continue when the message below 

appears.  

 

 

4. The “Import SimaPro Database” dialogue box will appear: 

Database management tips 

If you notice any older database updates (named Update1020, Update1030, or similar), you 

can delete these with Windows Explorer to free up disk space and avoid confusion. To avoid 

deleting useful databases by accident, please open each database before deleting it to check 

for any projects that need to be kept. 
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5. Click “Browse”. The update database (Update1040) will appear in the “Open Database” 

dialogue box. In multi-user versions, the field “Server” is also shown. Choose “None (single-

user access)” to perform the update locally (see step 1 and Box 1 in section 3.1).   

 

 

If you do not see the “Update1040” database, click the ‘’Browse’’ button in the Open database 

window. By default, the ‘’Update1040’’ database will be installed in the default directory (see 

Box 2 in section 3.1). Otherwise, browse to the directory where you installed the update 

database. Then, select the “Update104001.nx1” file and click ‘’Open’’. If you encounter “Cannot 

read user info” error when trying to open the “Update1040” database, please refer to this 

article to solve it.  

 

6. Click ‘’Open’’. You will see the libraries that need to be imported. Click “Select all” at the 

bottom left of the window. Next, click “Import”.  

 

https://support.simapro.com/s/article/How-do-I-solve-Cannot-read-user-info-error-when-importing-a-SimaPro-database


Update instructions SimaPro desktop 10.3 to 10.4 

11 

 

 
 

7. The data will be scanned and an overview will be generated of all the data that are added or 

replaced. Depending on the number of libraries that will be imported, this process can take 

quite some time. Once the scan is done, we recommend that you save this overview for your 

perusal. 

 

 

8. Click “OK” and SimaPro will verify the new processes to be imported 

 

 

9. Before data importing starts, the program will prompt you to make a backup. Select the 

folder and file name of your backup file. The default location of the SimaPro backup is 

C:\Users\[Your Windows User Name]\Documents\SimaPro\Backup. The backup file name 

contains timestamp and has the extension of .SPBackup. Once you click “Save”, SimaPro will 
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start creating a backup of your database. Note: this can take some time, depending on the 

size of your database. If you click Cancel, the update procedure will be stopped. 

 

 

10. The data in the Update1040 database will now be imported into the existing database. Note: 

this step can take some time (depending on the size of the database). SimaPro may seem 

unresponsive even if the update appears to be finished so please be patient as forcing 

SimaPro to shut down may risk database damage. For users with multi-user license, see the 

update tips in Box 1 (section 3.1) to speed up the update process.  

 

 

11. After the import is successfully completed, the below window will be shown 

 

 

Your data libraries and methods should then be updated. As a quick check: you should now 

have ecoinvent 3.12 in your projects list (make sure to first uncheck “Hide library projects”). 
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Not all ecoinvent libraries will be updated after import 

With this SimaPro release, only the ecoinvent 3 – allocation, cut-off by classification (unit 

and system) libraries are included by default in the SimaPro Professional, Update1040, 

FullUpdate1040 databases. As such, after updating your database, the ecoinvent 3 – allocation, 

cut-off by classification data library will show version 3.12 while other ecoinvent libraries (APOS 

and Consequential) will remain unchanged (so their version number may show as 3.11 or 

earlier). If you wish to update those additional libraries as well, the latest version will soon be 

available from this webpage and then you can import them in your updated database following 

the same instructions as explained in this manual. 

 Box 3. Import errors 

Should SimaPro report any import errors, please save the log file and make screenshots if 

possible. The overview of issues in the log file may help you to find out what went wrong. For 

assistance, please send an email to the SimaPro helpdesk at support@simapro.com and 

include the log file and any screenshots as attachments.  

We appreciate it if you could include the results of the database check, which can be done via 

File > SimaPro Database Management > Check Database. 

 

 

https://simapro.com/products/ecoinvent-apos-consequential/
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3.4 Appending Substances 
The next step is to do an “append substances” action to convert some old substance names in 

your database to the latest substance naming convention in SimaPro. If you do not do this, 

mismatches between life cycle inventory and impact assessment data may occur, leading to 

incorrect LCA results. The replacements are defined in the append file that is installed with the 

SimaPro software update. 

Appending merges two synonymous substance names into one. For example, CO2 needs to be 

appended to Carbon dioxide, the latter being the name used in the most recent version of 

SimaPro and in the impact assessment methods. Without appending CO2 to Carbon dioxide, any 

use of the substance named CO2 in processes will not show in the impact assessment results. To 

perform Append:  

 

1. Go to the ‘’Substances’’ section under General Data in the LCA Explorer screen.  

2. Click ‘’Append’’. A new window will open.  

3. Click Load on the right-hand side of the window and select the append file: 

AppendSubstances1040.xlsx. The append file can be found in the default database directory 

C:\Users\Public\Public Documents\SimaPro\Database. Note: If no data are loaded, your 

database is up to date! 

4. Click ‘’Append’’ on the right-hand side of the window.  

5. On the following prompt, click “Continue”. 

 

6. After final confirmation and an option to make a backup file, the substances will be 

appended. Depending on the size of your database, this may take some time.  

7. Once you see the following window, the Append process has been done successfully 

 

Prompts on Append 

We strongly recommend you to run Append whenever you import data libraries. When 

running append, it is possible that you may see different prompts, such as:  

 

1. The selected append file doesn’t contain any data that can be processed for this database 
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3.5 Updating obsolete links in your projects to ecoinvent 3.12 
Since ecoinvent 3.1 to 3.11 will be replaced by the updated 3.12 library, the majority of links will 

be updated automatically to ecoinvent 3.12. However, a number of processes are no longer 

supported and are considered obsolete.  

 

This warning means that there are no new substances to be appended. Your data is already up 

to date and you are good to go. You can simply press ‘’OK’’.  

 

2. Conflicts on Append 

 

If you receive conflicts upon appending substances like the above window, it implies that there 

are two synonymous substances that are both used in a single impact category but with 

different characterization factors. When this happens, SimaPro offers to use the factors of the 

target substances. You can safely remove these conflicts by clicking Details > Remove conflicts 

and make sure to store the conflicts. After that, the append will proceed. 

How can I tell which processes are now obsolete? 

The quickest way to review the obsolete processes is by checking the ‘Obsolete’ sub-categories 

in the ecoinvent 3.12 processes for material, energy, transport, etc. (Inventory > Processes > 

Material > Others > Obsolete). In the Documentation tab of these processes, the Comment 

field states that the correspondence process is no longer part of the ecoinvent 3 database (see 

screenshot below). If you select any of those processes and click on ‘Used by’, you will get an 

overview of the projects which are using the selected obsolete process.  

In addition, if you calculate a process or product stage that is or contains an obsolete process, 

you will get a warning message. The warning message indicates which process(es) are 

obsolete. You can then replace them using the replacement files (if possible) or manually. 
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Considering that you may have used some of these obsolete processes in your projects, we have 

created a special replacement file to allow you to change most of these obsolete links from older 

ecoinvent 3 versions to the correct processes in ecoinvent 3.12 in a fast and easy way. With this 

update, the following replacements file is available: Replace EI 3.x to 3.12 Cut off library.xlsx. The 

replacement file can be found in the default database directory: C:\Users\Public\Public 

Documents\SimaPro\Database (see also Box 2 in section 3.1).   

 

Please note that using the replacement files does not replace all obsolete processes. Some 

processes are disaggregated into more specific products or regions. In these specific cases, users 

should assume and decide themselves which activity is the best replacement. SimaPro will 

generate a warning when you make a calculation and finds that an obsolete process is still being 

used in your model. In that case, you need to manually replace the process with a process that is 

more suitable. See section 4.5.2.2 for further instructions on how to do manual replacement.  

 

 

 

 

Replacement files for APOS & Consequential 

With this SimaPro release, only ecoinvent allocation, cut-off by classification is included by 

default in the SimaPro database (Professional, Update1040, FullUpdate1040). If you wish to 

also replace obsolete links for ecoinvent APOS & consequential, you can download the 

database separately from this webpage. The replacement files are then included in the 

installer.   

Obsolete processes not included in the replacement files  

Please review the spreadsheet to check the reason why the activity from the previous version 

of ecoinvent does not exist in ecoinvent 3.12 anymore. 

https://simapro.com/products/ecoinvent-apos-consequential/
https://pre-support.sharefile.com/d-s2324625c57324e10be11c46d228b3440
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3.5.1 Using the replacement file 
Follow the next steps for replacing the obsolete links in your project using one of the 

replacement files.  You can also refer to this video for general instructions on using the tool: 

Projects to Libraries Links Manager. 

1. Open a project in your updated database. This can be any project.  

2. Go to Tools > Projects to Libraries Links Manager. 

3. Select the project(s) of which you want to change links (or press Ctrl+A to select all projects 

and another press of Ctrl+A to deselect). You can also use the filter to select project(s) by 

(part of the) name. 

4. Select the library where you want to replace the links (for instance, Agri-footprint).  

Note: make sure that this library is also selected in the Goal and scope > Libraries section in 

SimaPro. 

5. Click ‘’Scan’’. 

6. View the links found by clicking on the tab ‘’Links’’.  

7. Click on the ‘’Import replacements’’ button. 

8. Select the appropriate replacement file which can be found in the default database directory 

(see Box 2 in section 3.1) and click ‘’Open’’. 

9. Check the links which are going to be replaced in the column ‘’Replace name’’.  

Note: It is possible that there are no replacements found.  This means that the projects you 

selected do not contain links that can be replaced using the replacement files.  Nevertheless, 

there may still be some links that need to be replaced manually. 

10. Store your links in order to be able to check afterward. It is also possible to add new 

replacement links yourself.  

11. Click ‘’Replace’’ to replace the links to the chosen library. You will get a message on how many 

links are replaced to the chosen library. 

 

Tips in updating the obsolete links 

It is recommended to first use the replacement files to replace as many links as possible. After 

that, if you receive a message while calculating in SimaPro that your model includes obsolete 

processes, you can replace those manually. You can also filter only on obsolete processes by 

selecting ‘’only show obsolete processes’’ menu on the bottom left of the window: 

https://www.pre-sustainability.com/video-projects-to-libraries-links-manager
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3.5.2 Manual replacement (or creating your own replacement file) 
Once you determine that your project(s) still contain obsolete links, you can replace these 

manually by selecting an alternative process in the relevant process or product stages records.  

You can also use the Projects to Libraries Links Manager to manually replace multiple links that 

were not replaced using replacement files (please also refer to this video for an example). 

1. Go to Tools > Projects to Libraries Links Manager. 

2. Select the libraries where you want to replace the links.  

Note: make sure that these libraries are also selected under the Goal and Scope > Libraries 

section in SimaPro. 

3. Click ‘’Scan’’. 

4. View the links found by clicking on the tab Links.  The column ‘’Child name’’ shows the original 

links. 

5. Double click any of the empty cells you want to replace under the column ‘’Replace name’’. 

6. A dialogue box will open in which you can choose an alternative link in the preferred library. 

Use the function ‘’Show as list’’ on the right-hand side of the screen to list all links. Filter the 

links from the preferred library by entering the suffix of that library in the filter box at the 

bottom of your screen. 

7. Choose the preferred link and click ‘’Select’’. 

8. You will get a message: ‘Links referencing the same product. Use the selected replacement 

for them too?’ These are the same links which are used in different projects or within 

projects. Choose ‘’Yes’’ to replace all links. If you click ‘’No’’ only the selected link will be 

replaced. 

9. Click ‘’Replace’’ to replace the links. If you want to replace all links at once and you did not 

finish the work, you can export the previously selected links to Excel and import them at a 

later stage by clicking ‘’Export replacements’’ and saving your replacement file. 

 

You have now finished the update procedure! Repeat for any other database you wish to update. 

   

https://www.pre-sustainability.com/video-projects-to-libraries-links-manager
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4 Contact us 
Please contact us or your local partner if you have questions about new features in the SimaPro 

software or database, or if you have any other questions related to the update.  

• In SimaPro: Help > Contact SimaPro Support (recommended) 

• E-mail: support@simapro.com  

 

https://simapro.com/global-partner-network/
mailto:support@simapro.com

