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1 Single user installation

The SimaPro installation file installs temporary and indefinite licenses of SimaPro single user
version. You have to enter the SimaPro registration name and code during the installation.

The installation program will install the SimaPro version and accompanying databases based on
your registration name and code. After installation, activation is required when you start
SimaPro, except for the educational SimaPro Faculty license.

Activation

Please note that for each user license you have one activation, i.e. only one installation is
possible. To move SimaPro to another computer, you first need to de-activate. Deactivation is
only possible by uninstalling the software while connected to the internet.

1.1 Installation procedure

Step 1: Download the Single user installation file from:
https://support.simapro.com/articles/Article/SimaPro-Installation/

Step 2: Double click the SetupSimaProNNN.exe file to start the installation of the software and
the database.

Step 3: Follow the instructions on the screen.

Note: the end-user needs read-write access to the directory where the database is installed. You
can choose a different installation directory for the database (please see section 1.2), for
example, a server drive. This may be preferred for backup reasons.

Step 4: Upon starting SimaPro for the first time, you are asked to activate your license. You can
do this automatically via the Internet. If the connection with our activation server is blocked by a
firewall, please choose one of the manual options. For more information about firewalls, please
refer to section 2.2.4. To read more about activation, please see chapter 4.

Now you are ready to start using SimaPro!

1.2  Using the single user database on a network drive

It is possible to use the database on a network server. This may be preferred for backup reasons.
Please note, however, that a single user database can only be opened by one user.


https://support.simapro.com/articles/Article/SimaPro-Installation/
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During the installation, you can indicate the drive and path where the SimaPro database must be
installed. If you have already installed the database in the default directory, you can move it to a
new location.

First, make sure SimaPro is closed before moving the database. A SimaPro database consists of
77 numbered files with the extension *.nx1 (from ***00.nx1 to ***76.nx1). It is important that
you copy or move all files at once, as the files are interconnected. You can locate these files using
Windows Explorer, or please refer to Appendix 2: SimaPro Directories for the default locations.
Select all files or the database folder and move it to a new location on the server (using Copy and
Paste functions). Next, start SimaPro, and go to File > Open SimaPro Database. Choose Browse
to select the database directory on the server.

2 Multi-user installation

SimaPro multi-user installation installs both temporary and indefinite licenses of all SimaPro
multi-user versions, including the educational Classroom version. You must enter the SimaPro
registration name and code during the installation.

The multi-user version is a client-server application. Therefore, the installation consists of 2 steps
in the following order:

1. Installing the SimaPro Database Server

2. Installing the clients

The installation program will install the SimaPro version and accompanying databases based on
your registration name and code. After installation, activation is required - except for the
educational Classroom version.

Activation

Please note that for each user license you only have one activation, i.e. you have as many
installations as you have users. To move the SimaPro client to another computer, you first
need to de-activate. Deactivation is only possible by uninstalling the software while connected
to the internet.

2.1  Multi-user configurations

SimaPro multi-user is a client-server application. The c/jentis the SimaPro multi-user software,
which performs the calculations and handles the user input. The serveris a program that
controls the storage of the data and checks the number of users and is called the SimaPro
Database Server. The SimaPro Database Server allows multiple clients to work within a single
SimaPro database.
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Thus, you need a computer (e.g. a server) to run the SimaPro Database Server and one or more
computers (desktops or laptops) to run the SimaPro multi-user clients that connect to the
SimaPro database server.

In most cases, you use a Windows Server or a dedicated windows computer to run the SimaPro
Database Server. However, we recommend to install both the client and the server on the same
computer for optimal performance.

When the SimaPro database server and SimaPro clients are connected by a wired Local Area
Network (LAN), the SimaPro Database server can be installed on a network server. In case a
wireless network is used, it has to be a high speed with high bandwidth network to be able to
handle the large data traffic. Otherwise, calculations might be slow.

When the connection is a long-distance connection (WAN), VPN, or remote sites, then the
SimaPro Database Server should be installed on an application server like Microsoft Remote
Desktop, Azure, or Citrix XenApp (see Appendix 3: Terminal Server Configurations), as direct
access will be too slow.

2.2 Configurations on a Windows network

2.2.1 SimaPro Database Server on a network server
The default configuration is:
e SimaPro Database Server: on Windows Server 2012, 2016, or 2019 server (32 or 64 bit)
e SimaPro client: on Windows 10
e Protocol: TCP/IP
e Network: Wired Ethernet

2.2.2 SimaPro Database Server on a workstation

SimaPro Database Server can be installed on any workstation with a Windows operating system.
When a SimaPro user wants to run SimaPro multi-user, both the workstation and SimaPro
Database Server must be running so SimaPro can connect to the multi-user database.

The SimaPro Database Server and SimaPro client can be installed on the same computer.

2.2.3 Installation on a terminal server

You can install the SimaPro Database Server and SimaPro client on an application server like
Microsoft Remote Desktop, Azure, or Citrix XenApp (see Appendix 3: Terminal Server
Configurations). This is recommended in case of long-distance connections (WAN), VPN, and
remote sites, as direct access will be too slow to work. The maximum amount of concurrent users
is defined by the license.




Installation manual | SimaPro 9.4

The users connect to the terminal server. Both server and client are installed on that
computer/server. Users start SimaPro within the server machine to which they are connected.

Depending on the configuration, activation for each “user box” may be necessary.

No installation of SimaPro on client computers is needed, only the client software of the terminal
server. In case of Windows Remote Desktop Connection, it is included in Windows XP and higher.
In case of Citrix, the Citrix client has to be installed once per workstation.

2.2.4 Firewalls

SimaPro uses TCP/IP ports 16001 and 17001. If a firewall blocks these ports the SimaPro
Database Server will not be found. Note that older SimaPro versions used ports 16000 and
17000.

Some firewalls recognize new executables by size and version number. After an update, you
might need to reconfigure your firewall.

From Windows XP, the SimaPro software is added to the accepted programs list of the firewall
during installation.

2.2.5 Compatibility with Antivirus software

We found that some antivirus programs can interfere with the operation of the database server
when they detect that database files have changed. In these situations, users may receive access
violation errors at what appear to be random intervals.

To avoid these problems, it is recommended that you add the .NX1 files in your data directories
to the list of virus scan exceptions. This will prevent the antivirus software from obstructing
access to your data. Please see section 2.3.1 and section 2.3.4 for more information about default
data directories and the aliases that reference them.

2.3 Installing SimaPro Database Server

You can install the Database server as a console application or as a service. On most servers, it is
recommended to install as a service. The difference between a service and a console application
is that you have to start the console application to get it to work, like any other software package.
A service, on the other hand, is started automatically when the computer starts. It usually does its
work ‘in silence’ and unattended.

| Before you install

Please make sure that you have Administrator rights for the computer to install the software.
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2.3.1 Installation as a standalone application

Follow this procedure to install the database server as a standalone application. Please note that
we recommend this installation is done by experienced personnel in your IT department.

Step 1: Download the Multiuser installation file from
https://support.simapro.com/articles/Article/SimaPro-Installation/ and unzip
SetupSimaProNNNMulti.zip.

Step 2: Right-click SetupServerNNN.exe and select ‘Run as administrator’ to start the installation.
Follow the instructions on the screen.

Select ‘As standalone application’ when asked ‘Install SimaPro Server as a service or standalone?’

Note: you need to run this as an Administrator (the database server needs read-write access to
the directory where the database is installed).

Default directories

The default directory for the software is C:\Program files (x86)\SimaPro Server

The default directory for the database is \Users\Public\Documents\SimaPro\Database’ in
Windows 11, Windows 10, Windows Server2012, Windows Server 2016, Windows Server 2019.

You can then proceed with section 2.4 for installing the multi-user clients.

2.3.2 Install SimaPro Database Server as a service

Only for system administrators

Installing SimaPro Database Server as a Service has the advantage that you do not have to login
into Windows Server to start the SimaPro Database Server.

Step 1: Download the Multiuser installation file from
https://support.simapro.com/articles/Article/SimaPro-Installation/ and unzip
SetupSimaProNNNMulti.zip.

Step 2: Right-click SetupServerNNN.exe and select ‘Run as administrator’ to start the installation.
Follow the instructions on the screen.

Select ‘As service’ when asked ‘Install SimaPro Server as a service or standalone?

A user named “SPServiceUser2"” is automatically created. This user is granted “logon as a service”
rights. SPServiceUser2 needs "local administrator" administrator rights (i.e. not on domain level).


https://support.simapro.com/articles/Article/SimaPro-Installation/
https://support.simapro.com/articles/Article/SimaPro-Installation/
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Note: this user is deleted on uninstall, however, the profile is not. You have to delete the user and
the user profile to erase all traces.

When SimaPro Database Server is ready and running, you can proceed with installing the
SimaPro multi-user (client), as outlined in section 2.4,

For system administrators

You can use the Windows Service Controller (Start > Run > services.msc /s) to review and
manage what the installer has created. The service name is “SimaPro 9.4 Database Server”.
Alternatively, the application “ServiceController” has been created to install, start, stop and
uninstall the database service.

2.3.3 Manually install as a service

To start the SimaPro Database as a service after installing as an application run the command:
NxServer /install /start /UserName:aUsername /Password:aPassword
You need a user that has “logon as a service” rights. You can check this in “administrative tools”,

“local security policy” (or Start->Run->secpol.msc /s) then “local policies”, “user rights
assignments”.

On installation as a service, SimaPro automatically creates the following user:
Username = 'SPServiceUser2'

Password = 'Exus2006$'

You can use these details if you want to install the service manually. For example, after testing
the SimaPro Database Server console application.

2.3.4 Change server settings

To change settings in the SimaPro Service, start the database server management program
(command: NxServer, or Start->All Programs->SimaPro Server->SimaPro Database Server). First,
the service is stopped. You can then make your changes. When you exit the management
program, the service is restarted with the new settings. Remember to run the management
program as an administrator (right-click the application icon and select: Run as Administrator).

! Important notice

Opening the database management program when the database is running as a service will
log out all current users!

10
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Information about the settings in the SimaPro database server can be found in the help file (Help
> SimaPro Help > SimaPro databases). The most common settings that are changed:

Server Name

This refers to the name of the server as it is shown in the SimaPro multi-user client. By default,
this is “NexusDB". If you change the name, you have to change it in all SimaPro multi-user client
installations as well.

To change the name of the server:
e Open the SimaPro Database Server (run as administrator)
e Go to Server > Server Engine
o Deselect the checkbox ‘Active’ to stop running the server
e Change the server name
e Click Apply to save changes

o Select the checkbox ‘Active’ to run the server again

Aliases (Database directories)

These are names for the directories where the SimaPro databases are stored. You can store
multiple databases in one directory. However, it is recommended to create an alias per database.
The directory is not visible in the SimaPro multi-user client, only the Alias is visible. The name of
the alias can only contain text, numbers, and underscores.

Example:
Alias = ‘Default’

Directory =\Document and settings\Public\Documents\SimaPro\Database’

To create a new Alias:
e Open the SimaPro Database Server (run as administrator)
e Goto Server > Aliases

e Enter a new Alias Name and Path, then click Add

2.3.5 Best practices for managing user groups with several databases

If you have groups of users who have their own databases and often work independently of each
other, there are some limitations to be aware of. Below you will find some guidelines you can
follow to simplify the independent management of these databases.

One drawback of creating several databases under the same alias is that all databases must be
closed if database management tasks need to be applied. Also, while database management

11
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tasks are being applied to one database, all other databases will be unavailable. These
management tasks include:

e Opening one of the databases with “local server” access;
e Checking for database errors; or

e Updating the library data or methods.

The solution to these problems is to create separate aliases for each database using the
management program (see section 2.3.4). At a simple level, each alias corresponds to a separate
directory on the databases server's file system.

Imagine the following scenario:

User group Alias Directory

Energy Energy C:\Document and settings\all
users\documents\SimaPro\Database\Energy

Consumer FMCG C:\Document and settings\all

goods users\documents\SimaPro\Database\FMCG

Medical Medical C:\Document and settings\all

users\documents\SimaPro\Database\Medical

If the above alias and directory structure is used, then all three groups can independently
manage their databases without the other groups being affected. Please remember to run the
database management program with administrator privileges (right-click the icon: Run as
Administrator) when adding aliases.

2.4 Installing SimaPro multi-user (client)

Please note: the SimaPro Database Server must be installed first!

The SimaPro installation installs both temporary and indefinite licenses of Professional multi-user
versions and educational multi-user Classroom. You must enter the registration name and code
during the installation. See the box below for important installation tips for multi-user.

You may need Administrator rights for the computer to install the software. Please contact your
IT department for details on how to log in with Administrator rights.

12
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Multi-user Important Installation Tips

For optimal and faster performance, it is recommended that SimaPro client is installed on the
terminal server. It is also strongly advised that SimaPro client, database server, and database
files are all located on the machine. This is because direct access over VPN from local clients to
database server is too slow. You can, for instance, set up a remote desktop server to which
users connect via VPN where SimaPro client is installed. Please refer to Appendix 3 for further
explanation about the virtual setup.

SimaPro Classroom

For installing clients for the SimaPro Classroom version, please refer to section 2.6 on
automatically configuring clients to avoid extra work.

Step 1: Installing SimaPro

Go to the location where you downloaded and unzipped SetupSimaProNNNMulti.zip. Double-
click the SetupSimaProNNN.exe to start the installation. Follow the instructions on the screen.

The default directory where the software is installed is C:\Program Files (x86)\SimaPro Multi user

Step 2: Activating the license

After starting SimaPro, activation is required - except for the educational Classroom license. You
can do this automatically via the Internet. If the connection with our activation server is blocked
by a firewall, please choose one of the manual options. See also section 2.2.4.

Step 3: Selecting the server

Upon starting SimaPro multi-user, you will get the ‘Open database’ window. In most cases, the
SimaPro Database Server name appears on the screen. It will show as SPSERVER@10.46.0.7,
SPSERVER@MYSERVER.MYDOMAIN or SPSERVER@EXAMPLE.ET (only examples!).

If a server name does not appear, click ‘Servers' then ‘Scan'. If the list stays empty, click ‘New’ and
type in the name of the SimaPro Database Server in your organization. You can find this name in
the SimaPro Database Server; it is a combination of the server name and the IP address
(ServerName@IPAddress). The server name is found under Server > Server Engine. The IP
address is found under Statistics > TCPIPv4Transport at the Local Address.

Type the name correctly as typing errors will prevent SimaPro from finding the server. Next, click
OK and SimaPro will try to connect to the SimaPro Database Server. If successful, a list of
locations will appear. Locations are aliases for directories on the SimaPro Database Server.

Note: only databases in one of the aliases can be opened. Aliases (an alias points to a location)
can only be created using the SimaPro Database Server software. If you use a professional
license, you can also select the local server in which you can use the browse options to point to a
local directory.

13
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Step 4: Log in to the database as Manager

By default, there is no password defined for the manager. Simply leave the password field blank
and press enter. To log in as one of the predefined users, use the user name as the password.

To change the manager password (highly recommended), or to create new users and user types,
go to Tools > User Management. The import wizard can guide you in creating multiple user
accounts (see section 2.7).

The Manager has all the rights to edit the database, import data, and create users and user types
with different access possibilities to the various projects. Please make sure that the person who
manages the database in practice, knows the manager password and the associated
responsibilities.

2.5 Using SimaPro Multi-user as a pseudo single user

All professional SimaPro multi-user clients can work as a pseudo single user version if the multi-
user client is installed locally. This means that users can work in SimaPro as if it was a single user
version on a database that is stored on the computer locally. This is especially useful for updating
databases or showing the result to clients on location.

Note: this feature is not available in the Classroom license.

SimaPro databases on the local hard drive can be opened by choosing “Local server” in the open
database window. Next, browse to the directory where the SimaPro database is located.

If you wish to copy a SimaPro multi-user database to the local hard drive, make sure no users are
logged in and that you copy all 77 *.nx1 database files at once.

Note: If you copy a multi-user database that is protected with a manager password, this
password is still needed to open the database locally!

We recommend that users work (edit/create) in the multi-user version, and local copies opened
in the “pseudo single user” are used for viewing or calculations only as changes made in the local
database will not be reflected in the multi-user database!

2.5.1 Transferring projects

Databases cannot be synchronized; projects can only be imported into another database,
overwriting the projects with the same name. Hence, try to work in the shared multi-user
database as much as possible. If users work in several pseudo single user databases this can give
synchronization problems.

To move projects from a local database to the multi-user database on the server, you need to
import the project(s) on which you have worked into the multi-user database. You need to use
the Import SimaPro Database function under the File menu, which is only available when you log
in as Manager.

14
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! Important notice

Never copy or move a database from your local hard drive to the location of the multi-user
database as this will overwrite all data and destroy all new work made by other users (unless
you are absolutely sure no one has worked in the database).

2.5.2 TCP Problems

Sometimes SimaPro cannot find the local database server. This is caused by the fact that
Windows disables TCP/IP when the computer is not connected to a network or internet. To
enable TCP/IP in this situation you need to activate the ‘Local loopback adaptor'. This is a setting
in Windows. Please refer to Microsoft Knowledge Base for installation guidelines.

2.6 Installing client software centrally (Classroom)

This procedure only works for the educational SimaPro Classroom license. Do not use it for the
professional multi-user version as deactivation of the multi-user client software will not be

possible.

In a multi-user environment with many clients, as is the case with the SimaPro Classroom, you
can use the following procedure to speed up the rollout. It also prevents you from updating all
client installations when an update is available since there is only one client to update.

1. Install the SimaPro multi-user client on the server in a Shared directory or a directory in
which the target group has read access. Alternatively, copy an existing SimaPro multi-user
client installation (SimaPro.exe + DLLs and other files) to a shared directory.

2. Copy the SimaPro.LCS file to this Shared directory as well. The default location for this file
is C:\ProgramData\SimaProLicense\Multi (Please note that this .LCS file can be hidden.
You may need to adjust the settings in Windows to show this folder).

3. Create a shortcut to the file SimaPro.exe on all users' desktops or start menus. You can
use logon-scripts, profiles, or other network management tools.

4. Use command line parameters in this shortcut. For an overview of all command line
parameters, please refer to the Help menu of the SimaPro Database server.

Example: F:\Shared applications\SimaPro\SimaPro.Exe /Server:SPServer@central.local
/Alias:default /Database:Professional

15
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Note: The command line parameters Server, Alias, and Database will not work if the user has
opened a database in SimaPro before.

2.7 Importing Users

You can import users via Excel with a wizard. Go to Tools > User Management > Users and select
‘Import wizard'.

1. Select Excel file where you define one column of user names (must be new)
Select the user type you want to give to all users.
You can choose to select existing projects or create a project for every user.

You can choose to create passwords.

uoA W

The results are stored in an Excel file that you can use to mail merge the users.

You can also directly write your choices (user name, user type, password, new and existing
projects, library selection plus default method) in a spreadsheet. An example can be found in
C:\Users\"your name"” \Documents\SimaPro\Exce\ExampleUserSpecifications.xIsx. You can
import this file via the “Import Excel” menu.

16
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3 Using SimaPro in special situations

3.1 Running SimaPro with terminal services

Because SimaPro is an executable software without requiring many dll's, you can easily run
SimaPro with Windows Terminal Service, Azure, or Citrix XenApp. SimaPro uses no special
external programs, except for the Excel link if Excel is running. If Excel is not running on the
computer, SimaPro reads the Excel files directly. See also Appendix 3: Terminal Service
Configurations for further details.

3.2  Running SimaPro on Apple or Linux

SimaPro works with Windows operating systems. Should you wish to run SimaPro on a
Macintosh, or a PC with Linux as an operating system, you need to use Windows emulation
software. As the emulation software itself will use a lot of internal memory, you may need to add
memory to your computer to achieve reasonable performance. Moreover, remote access to a
Windows computer on which SimaPro is installed may be a suitable workaround.

Please note: we do not support, nor guarantee the functionality of SimaPro on non-Windows
operating systems, even when it is run using emulation software. You do this at your own risk;
PRé or their local partners cannot provide any technical support to solve problems. For further
information on running SimaPro on Mac and Linux, please refer to this page.

4 Activation

When you first install SimaPro and register your license, you need to activate it. Activation is not
needed for the educational Classroom and Faculty licenses.

During the activation process, no personal information is collected. The activation is based on a
“machine-ID", which is generated by SimaPro from the hardware properties in a PC. This makes
the activation code specific for the computer for which it was requested.

Note: for each user license, you have only one activation. If you want to move SimaPro to a new
computer, you must uninstall the software while connected to the internet.

For more information on activation and deactivation, please check our SimaPro Help Center:
https://support.simapro.com/.

17
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5 Database backups

We recommend that you make regular backups. The backup should not be located on your own
PC, but on a CD or a server drive for example. If your server is centrally backed up every night,
make sure that all the SimaPro database files are included, that the SimaPro database is notin
use, and that it is indeed possible to retrieve the database from the backup file.

To create a backup, you can use the backup function in SimaPro, under File > Database
Management. If you make central backups, this information will be useful:

e When you make a backup, SimaPro must be closed and no users can be logged in in the
multi-user version.

e A SimaPro database consists of 77 numbered *.nx1 files, in the format
DatabaseName00.nx1 to DatabaseName76.nx1.

o All files must be saved at the same time, as they are interconnected.

e The default location of SimaPro databases for Windows 11, Windows 10, Windows Server
2012, Windows Server 2016, and Windows Server 2019 is:
C:\Users\Public\Documents\SimaPro\Database\

Needless to say: we sincerely hope you never need your backup!

6 Updates

PRé Sustainability will regularly make software and database updates available to users with a
valid service contract. To inform you of the availability of new updates, it is important that we
have your correct contact details, most importantly your e-mail address. Please notify us of any
changes in your contact details, especially if the main contact person for SimaPro changes.

You can check if updates are available via the ‘Check for update’ option under Help in the
SimaPro menu. This option will check if the latest software is installed, but not if all database
updates are done. The check is only available if you have a valid service contract. Additionally,
you will find information on available updates on the About screen.

Updates can be downloaded via our website and come with clear installation instructions. If you
do not have a valid service contract and want to install any updates, you need to upgrade to the
current version first. Please contact PRé Sustainability or your local partner for information on
how to order an upgrade.
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7 Language support

The SimaPro software can be run in various languages. To change the language in which SimaPro
is run, go to Tools in the menu and select Language. Although SimaPro will instantly update with
the selected language, not all text is translated the first time. Therefore we recommend to restart
SimaPro.

Note: the SimaPro database, help file, and manuals are only available in English.

8 Support

If you have any questions, first check the SimaPro Help Center to see if the answer you are
looking for is already there. If you live in a country where we have a partner, please contact our
correspondence partner to receive support in your own language.

To contact PRé directly, use the “Contact SimaPro helpdesk” feature under Help in the SimaPro
menu. This will generate an email with technical information about your license, which helps the
helpdesk to answer your question more quickly. Please give as much information as possible,
such as a clear stepwise description of the actions you made, screenshots, etc. that will help us to
understand your question and to reproduce your problem.

You can contact the SimaPro Support directly via:
e In SimaPro: Help > Contact SimaPro helpdesk (recommended)

o Web site : https://support.simapro.com/

e E-mail: support@simapro.com

e Phone: +31 33 4504010
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Appendix 1: SimaPro System Requirements

1 SimaPro single and multi-user client

1.1 Operating system
SimaPro is a 32 bits Windows application which also runs on 64 bits Windows. It runs on
e Windows 11
e Windows 10
e Windows Server 2012, Windows Server 2012 R2
¢ Windows Server 2016
e Windows Server 2019

It is highly recommended to have the latest service packs installed. Earlier operating systems are
not supported, which does not mean SimaPro could not work on these systems.

1.2 Internal memory

We recommend at least 4 GB of physical memory for 32 bits Windows and 8 GB (minimum 6 GB)
for 64 bits Windows.

1.3 Screen resolution

The minimum resolution for SimaPro is 1280 x 1024. A higher resolution is recommended.

1.4 Processor

Some parts of SimaPro (the database manager and parts of the calculation routine) are multi-
threaded. We recommend that you use a multi-core processor in combination with a 64 bit
operating system for optimal performance.

1.5 Hard disk

You need at least 20 GB disk space for your database(s) when using the single-user version. For
the multi-user version, the database is installed on the server. In addition, both the SimaPro
single-user and multi-user client may need up to 10 GB of free (local) hard disk space for
temporary files.
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2 SimaPro Database Server

2.1 Operating system

The SimaPro Database Server is a 32-bit Windows application, which also runs on 64 bits
Windows. It runs on

e Windows 11

e Windows 10

e Windows Server 2012, Windows Server 2012 R2
e Windows Server 2016

e Windows Server 2019

It is highly recommended to have the latest service packs installed. Earlier operating systems are
not supported, which does not mean SimaPro could not work on these systems.

2.2 Internal memory

We recommend at least 4 GB of physical memory for 32 bits Windows and 8 GB (minimum 6 GB)
for 64 bits Windows.

2.3 Hard disk

Although the SimaPro Database Server itself is small (10 MB), at least 20 GB space is needed for
the installed databases.
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Appendix 2: SimaPro Directories

Below you can find the default directories of SimaPro. It is assumed that C: is your default drive.

Software

Filenames: various

C:\Program files (x86)\SimaPro
C:\Program files (x86)\SimaPro Multi

C:\Program files (x86)\SimaPro Server

Manuals
Filename: *.pdf files
Subdirectory \Manuals (under Software)

Check the SimaPro Help Center for the most recent versions of the manuals.

SimaPro Database
77 numbered *.nx1 files, default name: professional00.nx1 to professional76.nx1

For Windows 11, Windows 10, Windows Server 2012, Windows Server 2016, and Windows Server
2019:

C:\Users\Public\Documents\SimaPro\Database\

License
Filename: simapro.lcs, simapro.aii

Windows 11, Windows 10, Windows Server 2012, Windows Server 2016, and Windows Server
2019:

C:\ProgramData\SimaProLicense\[Single/Multi]

User output and export
Filenames: *.txt, *.xIs, *.csv, *.bmp, *.xml

The default location is the user’'s “My documents/SimaPro/” directory.
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Appendix 3: Terminal Server Configurations

Using terminal server software such as Microsoft Remote Desktop, Azure, or Citrix XenApp is an
ideal way to use SimaPro when users have limited bandwidth. This is often the case when users
are connected to a Wi-Fi network, a WAN (wide area network), or through a VPN (Virtual Private
Network). VPNs often operate over public internet connections (see Figure 1).

At the time of writing, PRé has only tested SimaPro in conjunction with a VPN and Microsoft
Remote Desktop Services (RDP). Although no XenApp servers are currently available to PRé
Sustainability, the added overheads of such an environment are assumed to be similar to RDP.
When actual tests using these other packages are carried out, such experience will be added to
this document.

A number of our clients are currently known to be using SimaPro on XenApp or Remote Desktop
servers. While we cannot give technical support on these specificimplementations, we see no
reason why such configurations should be problematic. Indeed, we believe that the investment in
such environments will improve the user experience when bandwidth is at a premium.

For best performance each
terminal server session
should run on the same disk
array as the database server

and database files T -
- N
. N
. N
7 \\
i ’
SimaPro database Terminal server y \
server / \
! \
! \
| 1
@ 1 !
\ !
\ /
N Laptops A
P \ //
Wi-Fi Y y
\\ // )
~<_ Wireless LAN .~ Users connected via

S——— - - Wi-Fi or remote

network can access

SimaPro through
terminal server

LAN users can
access the
SimaPro
database server
directly or via
the terminal

server Router

Figure 1: Terminal Server Configuration
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SimaPro on Azure
The following procedure explains the SimaPro configuration on Azure:

1. Go to the Azure home page (https://portal.azure.com/).

2. Create an account if needed.

3. Click Virtual Machines. You will be directed to the Basics setup page.

4, On the Image section, select Windows Server 2016 Datacenter - Gen1.

5. On the Size section, select Standard_D4s_v3 - 4 vcpus 16 Gib. This is the size that you
need for the SimaPro server and 2 SimaPro Clients.

6. Click Next. You will be directed to the Disks setup page.

7. Leave the information as is on the Disks setup page. Please refer to the below picture.

Home > Virtual machines

Create a virtual machine

Basics Disks Networking Management Advanced Tags Review + create

Azure VMs have one operating system disk and a tempeorary disk for short-term storage. You can attach additional data disks
The size of the VM determines the type of storage you can use and the number of data disks allowed. Learn more

Disk options

05 disk type * @ | Premium $SD v ‘

Encryption type * | (Default) Encryption at-rest with a platform-managed key v ‘
. fs)

Enable Ultra Disk compatibility @ O ves (@) No

Data disks

You can add and configure additional data disks for your virtual machine or attach existing disks. This VM also comes wit!
temporary disk.

=
w

LUN Name Size (GiB) Disk type Host caching

Create and attach a new disk Attach an existing disk

~  Advanced

8. Click Next. You will be directed to the Networking setup page.

9. Leave the information as is on the Networking setup page. Please refer to the below
picture.
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Home > Virtual machines >

Create a virtual machine

Basics Disks Networking Management Advanced Tags Review + create

Define network connectivity for your virtual machine by configuring network interface card (NIC) settings. You can control
ports, inbound and outbound connectivity with security group rules, or place behind an existing load balancing solution.
Learn mare

Network interface

When creating a virtual machine, a network interface will be created for you.

Virtual network * () ‘ (new) Demo_group-vnet v ‘
Create new

Subnet* (@ [ tnew) defautt (10.0.0.0/24) v

Public 1P (O ‘ (new) Demo-ip ~ ‘
Create new

NIC network security group (3 QO nNene (®) zasic O Advanced

public inbaund ports * @ O MNone @ Allow selected ports

Select inbound ports * ‘ RDP (3389) ~

b This will allow all IP addresses to access your virtual machine. This is only
recommended for testing. Use the Advanced controls in the Networking tab to
create rules to limit inbound traffic to known IP addresses.

Accelerated networking @ @ an O off

Load balancing

You can place this virtual machine in the backend poel of an existing Azure load balancing solution. Leam more

Place this virtual machine behind an O ves @ e
existing load balancing solution?

10. Click Next. You will be directed to the Management setup page.

11. Select the field as shown in the picture below.

Create a virtual machine

Basics Disks Networking Management  Advanced Tags Review + create
Configure manitoring and management options far your VM.

Azure Security Center

Azure Security Center provides unified security management and advanced threat pretection across hybrid cloud workloads.
Learn more

9 vour subscription is protected by Azure Security Center basic plan.

Monitoring

Boot diagnestics @ (®) Enable with managed storage account (recommended)
O Enable with custom storage account
(O pisable

05 guest diagnostics (@ O on @ ort

Identity

System assigned managed identity (O O on @ ort

Auto-shutdown

Enable auto-shutdown ©
Shutdown time @

Time zone ©

Notification before shutdown &
Email * @

Backup

Enable backup ©

Guest OS updates

Patch installation &

® on O or

‘ 7:00:00 PM

‘ (UTC) Coordinated Universal Time

® on O off

@ OS-orchestrated patching: patches will be installed by O
O Manual patching: Install patches yourself or through a different patching

solution.
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Click Next. You will be directed to the Advanced setup page.

Leave the information as is on the Advanced setup page. Please refer to the below
picture.

Home > Virtual machines

Create a virtual machine

Basics Disks Networking Management Advanced  Tags Review + create

Add additional configuration, agents, scripts or applications via virtual machine extensions or cloud-init.

Extensions

Extensions provide post-deployment configuration and automation.

Extensions (D) Select an extension to install

Custom data

Pass a script, configuration file, or other data into the virtual machine while it is being provisioned. The data will be saved on
the VM in a known location. Learn more about custom data for VMs &

Custom data

@ Custom data on the selected image will be processed by cloud-init. Learn more about custorn data and cloud init &

Host

Azure Dedicated Hosts allow you to provision and manage a physical server within our data centers that are dedicated to your
Azure subscription. A dedicated host gives you assu hat only VMs from your subscription are on the hest, flexibility
chaose ¥Ms from your subscription that will be provisioned on the hest, and the control of platform maintenance at the level
of the host. Learn more

Hast greup @ No host group found ~

Proximity placement group

Proximity placement groups allow you to group Azure resources physically closer together in the same region. Learn more

Proximity placement group @ No proximity placem

VM generation

Generation 2 VMs support features such as UEFI-based boot architecture, increased memory and OS disk size limits, Intel®
Software Guard Extensions (SGX), and virtual persistent memory (vPMEM).

- @ : 5
VM generation @ (®) Gen1 () Gen2

Click Next. You will be directed to the Tags setup page.
On the Resource section, choose 12 selected and leave other field as is.

Click Next. You will be directed to the Review + create page. You will see the overview of
all the setup you have previously selected. After finished reviewing, Press Create.

Copy the SimaPro installers to the vritual machine and perform the normal installation
procedure.

Add at least one additional user to the server by clicking Control Panel > User Accounts >
Change account type > Add and then enter the user details.
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1 Technical requirements

This document is based on the experience of PRé Sustainability with its own in-house terminal
server. Its configuration is Microsoft Remote Desktop running in a VMware ESXi 4.0 virtual
machine on a Windows 2016 server with a maximum of 5 users'. Industry literature indicates that
XenApp offers better security, better load balancing features, and a more natural feeling when
connecting to the desired application. These features are more likely to be important when
implementing a solution with a large number of users. The points below are based on our
experiences and are by no means an exhaustive test of the capabilities and limits of such a
solution.

1.1 Server requirements

The minimum hardware requirements of the server are 4 GB of memory (RAM), a 2 GHz quad
core processor, and a Windows 2016 server. Fast SSD drives and about 2 GB of free memory are
important as a lot of data is transferred between the SimaPro database server and internal cache
buffers. For this reason, it is recommended to install the database server and files on the same
disk array as the terminal server software. More memory will only be a benefit if you install a 64
bit operating or if you create separate virtual machines for the SimaPro database server and
terminal server. Note that it is possible to have several installations of the terminal server with
the SimaPro client, all connecting to the same SimaPro database server.

Regarding the software, a default Microsoft Windows server installation only allows two remote
desktop connections and is designed primarily for system administrator access. In the majority of
cases, special “Terminal Server Client Access Licenses” have to be purchased from Microsoft for
each intended SimaPro user. Additionally, the “Terminal Server Licensing Service” will have to be
installed and configured. (Please note Terminal Services client access licenses (TS CALs) are now
called Remote Desktop Services client access licenses (RDS CALs)). For Citrix and Azure, please
refer to their website for details of the software and licensing arrangements.

"Out of the box" the professional database occupies 1 GB of disk space. This only grows
significantly when users copy entire libraries, especially those from ecoinvent. The database
server software can use up to 10 GB of temporary disk space when accessed by multiple users,
but this is managed dynamically based on available disk space.

We have no market preferences for any hardware. Our own server, which performs very well, has
a quad core CPU with 16 GB of RAM. Its good performance is likely due to its processing power,
its 15000rpm disks, its separation of different application servers using virtual machines, and its
connection to a 1 Gbps local network.

1 SimaPro supports up to 40 concurrent users. Memory limits of your terminal server are likely to be the
limiting factor when connecting a large number of users.
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1.2 Client session requirements

With Remote Desktop, each SimaPro client uses on gverage 250 MB with a session overhead of
about 50 MB. Each session should have access to the equivalent of a single core 1 GHz CPU.
Overworked local area networks (LANs) can have a serious impact on database functions, so itis
recommended to use a 1 Gbps network.

Processor and memory demands are relatively low except with functions such as calculating
network trees with unit processes, comparing network trees, performing Monte Carlo analysis of
several thousand runs, importing SimaPro databases, and copying projects, all of which require
large floating point matrices or data buffers to be manipulated. In extreme cases, the SimaPro
client can use more than 2 GB of memory so be careful not to limit the available memory.
Windows 10 or later is recommended for the SimaPro client, and Windows Server 2016 or later is
recommended for the SimaPro database server.

In case of complex calculations, SimaPro caches opened libraries in temporary files on the hard
disk. For optimal speed, it is recommended to have at least 2-3 GB free disk space while using
SimaPro. When SimaPro is closed these temporary files are deleted. If the user exports data, the
file size will vary based on the quantity of data selected, i.e. anywhere between a few KBs and 1
GB. Exporting graphs requires only a few kilobytes for JPEGs and about 1 MB for bitmap files.

1.3 Remote client requirements

Requirements for the remote client software are very low with the most important requirement
being a stable communication link. SimaPro does not make use of animation or sophisticated
graphical features, so a 128 Kbps upload/download link should suffice.

For security reasons, we recommend that terminal sessions should not be run from a public
computer. Extra protection can be implemented by hosting the terminal server in a DMZ
(demilitarized zone) or requiring a secure VPN connection to the network hosting the terminal
server.

2 Installation

There are no special requirements for the SimaPro client on a terminal server that differs from
the installation of any other software packages in this kind of environment. With Citrix XenApp
and Azure, the SimaPro client should be loaded in ‘install mode’. As mentioned before, please
install the SimaPro database server, database files, and SimaPro client program on the same disk
array for optimal performance.

The SimaPro multi-user version operates as a client-server system. Although not ideal, if the
client and database are separated by a firewall device, then TCP and UDP ports 16001 should be
open (for unsecured transport) and 17001 should be open (for secured transport).

28



Installation manual | SimaPro 9.4

It is common for terminal server sessions to have limited directory creation privileges. To allow
correct registration and activation of SimaPro, each session running the SimaPro client should
have read/write access to the “Document and Settings” and “ProgramData” directories mentioned
in Appendix 2: SimaPro Directories.

PRé Sustainability does not offer software installation services. Our helpdesk will, however,
answer any specific questions where possible and suggest other options to explore for questions
outside their area of expertise.

3 Maintenance

Backups

The SimaPro database files can be backed up in a multi-user environment, providing no access
for users to edit the database. Unfortunately, no special software agents are available to
guarantee a tape backup system can archive the database when it is being used. An alternative
method is to use the manual backup function within the SimaPro client software. We recommend
performing regular nightly backups in the early hours of the morning when all users are likely to
be logged out.

Database Server Crash

In the event of a database server or machine crash, large temporary files may be left in the
default Windows TEMP directory. In such cases, you need to remove these SimaPro database
server files manually. They can be recognized by the format: XXXX_XXXXXXXX.tmp. The SimaPro
client will always remove its temporary files automatically upon restarting the application.

Database and Program Administration

Each database has a Manager user with its own password. This is required to create user
accounts and set project access rights (via Tools > User management). The database Manager has
full access to all data and projects within a database.

We recommend the client software is installed in a central location and a shortcut is made in
each client environment, as this minimizes the work needed when a client update is available.

Locked User Sessions

When using terminal sessions and SimaPro, it is possible for users to close their terminal
sessions without shutting SimaPro down. This can occur if their communication link is broken or
sometimes it is done intentionally, so users do not need to close off all their work (see

Figure 2). When this occurs, the SimaPro client session stays active, which prevents the license
from being used by someone else. Additionally, in rare cases, SimaPro can crash but its process
stays active in memory, even though no user interface is visible. This will stop the same user from
being able to log back into SimaPro.
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Applications I Processes I Performance I MNetworking  Users |
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Figure 2: Disconnected but active remote desktop session

The solution to these occurrences is to either:
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e Open the terminal session again and shut it down properly, i.e. Log off; or

o Open the Task Manager (left-click the task bar), select SimaPro.exe, and click End Process

(see Figure 3)

The latter option should only be done as a last resort as it does introduce the risk of corrupting

the database.
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B windows Task Manager =l B3
File Options W¥iew Help
Applications  Processes |Perfnrmance I Networkingl |Users I

Irnage Mame | User Marmne | CPL | Mern Usage | ;I
lsass.exe SYSTEM an §.872K
mdri. exe SYSTEM on 3036 K
madkc. exe METWORE SERVICE an 4 172K
POWERPMT.EXE Marisa oz 34.732K
rdpclip.exe ru_simapra ] 3856 K
rdpclip.exe 53_simapro i} 1372k
rdpclip.exe Marisa aa 1.104 K
Rbvscan.exe SYSTEM Juln] 4. 796 K

services, exe SYSTEM oo 12,3258 K
Sima = :
SimaPrao.exe ru_simapra an 1.856 K

Smc.exe SYSTEM un] 4,584 K
SmcGuiexe sa_simapro on 6,205 K
SmoGuiexe Marisa oo 4,752 K
SmcGuiexe ru_simapra uli] 6,352 K
SMSS, BXE SYSTEM un] 455 K
SNMp.Exe SYSTEM an 4. 770K
spoolsy, exe SYSTEM uli] G344 K
svchost, exe SYSTEM un] 3.320K

V¥ show processes from all users End Process |

[

|F‘rocesses: 66 |CPU Usage: 2% Commit Charge: 537M | 59920 2

Figure 3: Terminating SimaPro
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