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About SimaPro 
SimaPro was developed by PRé with the goal of making sustainability a fact-

based endeavor. PRé has been a leading voice in sustainability metrics and 

life cycle thinking development for nearly 30 years, pioneering the field of 

environmental and social impact assessment. We develop tools that help 

you create value and drive sustainable change. 

SimaPro is distributed through a Global Partner Network. All partners were carefully selected by 

PRé. A partner in your country will act as your local SimaPro sales and support representative 

and can show you a personal demo or provide more information. 

Find your local partner: simapro.com/global-partner-network 

 

Get in touch 

T    +31 33 450 40 10 

E    support@simapro.com  

W   simapro.com   |   support.simapro.com   |   pre-sustainability.com 
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1 What to expect from Report Maker 
 

1.1 Why use Report Maker? 
If you’ve ever made a report based upon an LCA study you know that one of the most time-

consuming things that can happen is finding an error in your model just before having to present 

your report. You have to rerun all the calculations and copy or export all graphs and tables again 

to Word and Excel and adjust the layout. Also if you present draft results in a draft report, you 

know you will have to do the work all over again for the final version.  

SimaPro Report Maker solves that - you create your report in MS Word or Excel, use all the 

powerful layout features MS Word and MS Excel provide, and paste your graphs and tables there. 

After you have made modifications to your models in SimaPro, you just press one button in your 

report and all graphs and tables are updated with the newest results. SimaPro automatically 

performs the calculations and Word and Excel import the graphs. 

In short, you can use Report Maker to: 

 Update draft reports 

 Easily update reports after adapting a SimaPro model. 

 Automatically update reports of recurring calculations (EPD calculations for example) 

 

1.2 What does Report Maker do? 
Report Maker allows you to incorporate text and LCA results (graphs and tables) from SimaPro in 

MS Word and Excel 2010 and up, and keep those updated as per your SimaPro model. 
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2 Getting started 
 

Once you have installed Report Maker, new functions will be made available in SimaPro, Word, 

and Excel, as explained below. 

 

2.1 In SimaPro 
You will see an extra menu item called "Copy Item Descriptor" if you right-click the background 

area of a graph, table, or text area. An item descriptor identifies a graph, table, or piece of text in 

SimaPro. You paste item descriptors into your document and Report Maker will later expand 

them to the described data. 

 

 

 

  

2.2 In MS Word and Excel 
An extra tab in the Office Ribbon will be added with the functions shown below. 

 

 

These functions will help you keep your reports up to date with the changes you make in your 

SimaPro model. Instead of copying your graphs to MS Word or MS Excel, you can now only copy 

the item descriptor and paste that in your report.  

If you then click "Update Current Descriptor", SimaPro will calculate the results and the descriptor 

will be replaced by the graph, table, or text area. If you click "Update All Descriptors", all items in 

that document that have been copied from SimaPro will be updated with the new results.  

Detailed steps on how to use these functions are outlined in the following sections. 
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3 How to use Report Maker 
 

First-time SimaPro users  

If you use SimaPro for the first time and don’t have a project to work with yet, please use the 

project “Introduction to SimaPro” (File > Open Project) for purposes of this manual. You can 

use the life cycle of the Coffee machine model for your calculations (see screenshot). 

 

 

3.1 Copy the item descriptor from SimaPro 
 

(1) Create your model in SimaPro and run a calculation. 

Make sure that your calculation setup contains a 

method, even if you only want to create an inventory 

table.  

(2) Find a graph you would like to include in your report. 

Please note that Report Maker does not support 

copying Network/Tree views. 

(3) Right-click the white area around the graph (or table) 

and select the option “Copy Item Descriptor”.  

 

 

 

3.2 Create graphs and tables in your report 
Open your document or worksheet, set the cursor where you would like to insert the graph, and 

paste this item descriptor (Ctrl+V or right-click > Paste). The item descriptor contains the 

instructions for SimaPro to recreate this graph or table again.  

 

Example of an item descriptor pasted in MS Word: 

Impact assessment chart of damage results with Analyzing 1 p ‘Life cycle Pro, no takeback’ 

 

1 

2 

3 



  Report Maker 3 | User manual 

7 

 

 

Example of an item descriptor pasted in MS Excel: 

 

 

Next, click “Update All Descriptors” or “Update Current Descriptor” 

(your cursor needs to be in the item descriptor field) in the SimaPro 

Ribbon. SimaPro will start to calculate and after a few seconds up to 

a few minutes (depending on the size and the complexity of your 

model in SimaPro), your graph or table will appear. 

 

The table or graph always appears above the item descriptor in MS Word. The table with results 

from SimaPro will appear below the item descriptor in MS Excel, overwriting all data that was 

previously shown in those cells. So leave enough space below an item descriptor - at least 12 

rows more than the size of the table itself. 

 

Creating graphs or tables in Excel 

In MS Excel, pasting item descriptors will only create tables.  This allows you to use MS Excel’s 

formatting power to create the exact layout of the graph that you wish. To easily create a 

graph, select the cell with the item descriptor and choose Insert > Chart. A chart will be created 

automatically. 

Please note that there is a difference between creating an item descriptor from a graph or 

from a table in SimaPro. An item descriptor from a table will also include the totals per column, 

whereas the item descriptor from a graph will not include the totals.  

 

3.3 Update graphs and tables 
After creating the tables or graphs using item descriptors, you can still go back to SimaPro and 

make changes to your model. Once you have finished the changes, return to your documents 

and click “Update All Descriptors” or “Update Current Descriptor” to get a newer version of your 

graph or table.  This updated version will include all changes that you have made to your model 

in SimaPro. 

 

What can I change in my SimaPro model? 

There are some limitations to the changes you can make to your SimaPro model, while still using 

the same item descriptors in your report.  For example, the items and options you define in your 

calculation setup cannot be edited.  Meanwhile, changes to the underlying product stages, 

processes, amounts, etc. will be incorporated and updated automatically in your report. 
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If you want to make changes to your calculation setup (for example, by choosing another impact 

assessment method), the item descriptor will not be updated.  Instead, you have to create a new 

item descriptor and paste that in your report. 

 

Editing the graph layout in MS Word 

Double-click a graph in MS Word to change its layout and design. This will enable the “Excel 

modus” in MS Word (some buttons will now be disabled in the SimaPro Ribbon) and now you can 

start changing the layout of your graphs. Please check the layout of a graph after updating it, as 

the formatting/layout of a graph may be lost in some cases, for example: 

 if the number of columns or rows before and after the update is different, 

 if the text from SimaPro that was entered by Report Maker but later manually changed by 

the user has been updated (for example, editing the wording in the legend). 

 

Moving a table in MS word 

If you want to move a table in MS Word, then copy the item descriptor and paste it on the page 

where you want to have it. If you just move the table, the link to the item descriptor will be 

broken and the table will not be updated anymore. 

 

3.4 View or edit item descriptor in MS Word and MS Excel 
 

To see the exact settings that were used to create the graph or table in 

SimaPro, you can click “View/Edit All Descriptors” or “View/Edit Current 

Descriptor” (in this case your cursor needs to be in the item descriptor 

field).  

Under the tab ‘Calculation settings’ you can see full details regarding 

what is being calculated, for example, what method was used or if the 

calculation includes long-term emissions or infrastructure processes. 
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Under the ‘Source’ tab, you can change the database name, location, and server. This allows you 

to store the database and accompanying MS Word and MS Excel reports in a different location 

(for example to send it to a customer or manager) and still allow the reports to be updated. In MS 

Word, the caption of a graph or table can also be edited.  Please note that the name of the 

project cannot be changed. 

 

These are the only possible changes that can be done on this screen.  If you want to change what 

is calculated, you need to make a new calculation in SimaPro, create a new item descriptor, and 

paste that in your report. 

 

 

4 Advanced use 
 

In combination with SimaPro Developer, Report Maker provides you with a powerful, interactive 

reporting feature. It allows you to adapt and recalculate SimaPro models by changing values 

within your report in Word or Excel. 

SimaPro Developer allows you to make models with links to your data in Excel documents: 

 directly to the amount fields of process records, or 

 in the parameters section in the calculation setup (importing parameter sets from MS 

Excel in SimaPro). This is further explained in the next section. 

If you link these fields in SimaPro to your MS Excel report or to an MS Excel document linked in 

your MS Word report, then you can change values in your report and use Report Maker to show 

the results in graphs and tables right away (even with SimaPro closed). 

 

4.1 Using parameter sets 
Report Maker offers a way to generate multiple documents from SimaPro parameter sets. This 

can be useful when one wants to generate reports for different scenarios (where a scenario can 

be a slightly different product of a slightly different production process for the same product of 

whatever other diversification).  

SimaPro parameters sets allow you to define such scenarios and Report Maker allows you to 

create a report for each. This feature can, for instance, support your EDP reporting needs. 

 

 

 

 

 

 

https://support.simapro.com/articles/Video/Linking-Data-to-Excel/?
https://support.simapro.com/articles/Video/Importing-Scenarios-from-Excel/
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The steps below outline how to do this when using “imported parameter sets from MS Excel” in 

the calculation setup: 

1. Create a parameterized model in SimaPro. 

2. Create a MS Excel document with several sets of the parameters that you want to vary. 

3. Create a calculation setup with an imported parameter set (for more help with this step, 

please check this video). 

4. Run the calculation setup. 

5. Copy the item descriptors for the graphs (or tables) that you want to use in your report. 

6. Paste the item descriptor in your MS Excel worksheet (either on the same worksheet as 

where you defined your parameter values or another worksheet). 

7. Now you can change the parameter values in your excel worksheet and press the "Update 

Current Item Descriptor" button. Your graphs will represent the currently calculated version 

of your model. 

 

 

https://simapro.com/2016/how-to-import-scenarios-from-excel/
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5 Tips and troubleshooting 
 

Creating and updating text from SimaPro 

Apart from graphs and tables, you can also export text 

from certain text fields in SimaPro. For example, all text 

fields in the Description section (see screenshot) or 

process records can be incorporated in your reports. 

 

Saving changes in SimaPro  

Make sure you save the changes you have made in 

SimaPro before clicking “Update All Descriptors” or 

“Update Current Descriptor” in MS Word or MS Excel.  

 

Using Report Maker and SimaPro simultaneously 

Do not select “Copy Item Descriptor” while Report Maker is busy updating. 

 

Copying individual results 

Individual data such as CO2 emission to air can be used in Word by linking to the corresponding 

cell in Excel (Office functionality).  

 

Network/Tree and Monte Carlo 

Currently, Report Maker does not support the inclusion of Network/Tree views or Monte Carlo 

(uncertainty analysis) results. 

 

The graph appears strange in MS Word 

If a graph appears only partially or too large in MS Word, please double-click the graph to get into 

the Excel modus of Word and then click somewhere else in the document again. If the graph still 

doesn’t show correctly, select the graph and delete it. Then, select the item descriptor and click 

“Update Current Descriptor” to re-create the graph. 

 

MS Word or MS Excel crash during an update of the item descriptors 

After you click any of the update buttons, please do not use Word and Excel until the update has 

finished. 

 

Show/edit Item descriptor code 

Pressing Alt+F9 will show the item descriptor code.  If you make any changes in this code, you 

might not be able to update the graphs and tables anymore or the setup might have changed. 
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Library switching function does not work 

The library switch function which allows you to replace one library for another (e.g. Ecoinvent 

System library for Ecoinvent Unit library) in a calculation setup in SimaPro is not supported in 

Report Maker. In that case 

 

COM precautions with multiple SimaPro versions 

Because a COM-interface can be registered only once on a computer, there might be a conflict 

between multiple suppliers of that COM-interface. In practice, it means that the last SimaPro that 

is installed will replace the COM-registration. You can influence this in SimaPro by doing an 

explicit unregister + register action of the SimaPro version that you want to handle all COM-

functionality by clicking Help > Unregister COM server.  

 

Slow on computers with little memory 

For computers with limited memory, please close all other applications (also SimaPro) when you 

update a MS Word or MS Excel document. 

 

6 Backups 
 

Report Maker itself does not store any information. All information you enter is stored in 

SimaPro, and the MS Word and MS Excel documents which are updated. So please make regular 

backups of your SimaPro database and your documents. 

 

7 Updates 
 

PRé regularly makes available SimaPro software and database updates to users with a valid 

service contract. If you do not have a valid service contract, please contact PRé or your local 

partner for your renewal options. 

 

8 Support 
 

If you live in a country where we have a partner, please contact our correspondence partner to 

receive support in your own language. You can contact SimaPro Support directly via: 

 SimaPro: Help > Contact SimaPro Helpdesk (recommended) 

 SimaPro Report Maker ribbon (in MS Word or Excel): About > Support Email 

 Phone: +31 33 4504010  

 E-mail: support@simapro.com  

https://simapro.com/global-partner-network/
mailto:support@simapro.com

